WebAIM

web accessibility in mind

WCAG 2 Checklist

Principle 1: Perceivable
Web content is made available to the senses - sight, hearing, and/or touch

Guideline 1.1 Text Alternatives
Provide text alternatives for any non- text content

Success' Critena | Recommendatlons P

1.1.1 Non-text 0 All images, form image buttons, and image map hot spots have appropriate, equivalent
Content alternative text.
(Level A)

(1 Images that do not convey content, are decorative, or contain content that is already
conveyed in text are given null alt text (alt="") or implemented as CSS backgrounds. All
linked images have descriptive alternative text.

O Equivalent alternatives to complex images are provided in context or on a separate
linked page.

0 Form buttons have a descriptive value,

U Form inputs have associated text labels.

0 Embedded multimedia is identified via accessible text,

O Frames and iframes are appropriately titled.

Guideline 1.2 Time-based Media
Provide alternatives for time-based media

NOTE: If the audio or video is designated as an alternative to web content (e.g., an audio or sign language version of a
web page, for example), then the web content itself serves as the alternative.

’Success Criteria Recommendations

L2.1 Prerecorded £1 A descriptive text transcript that includes relevant auditory content is provided for non-

A!Jdlo"onl and live audio-only (audio podcasts, MP3 files, etc.)..

w 7 A descriptive text transcript or audio description is provided for non-live video-only
(e.g., video that has no audio track), unless the video is decorative.

1.2.2 Captions £1 Synchronized captions are provided for non-live video (YouTube videos, etc.).
{Prerecorded)
{Level A)

1.2.3 Audio (1 A descriptive text transcript OR audio description track is prowded for non-live video.
Description or NOTE: Only required if the video conveys content visually that is not presented via the
Media Alternative audio track.

(Prerecorded)
{Level A)

1.2.4 Captions O Synchronized captions are provided for all live multimedia that contains audio (audio-

%il’@ll AR) only broadcasts, web casts, video conferences, etc.}
eve

1.2.5 Audio 13 Audio descriptions are provided for all video content. NOTE: Only required if the video
Description conveys content visually that is not presented via the audio track,

( ) . . . C
Eretecorded 3 While not required at level AA, WebAIM recommends descriptive transcripts instead of
(Level AA) . . . . 0, . P

or in addition to audio descriptions for optimal accessibility.

1.2.6 Sign O A sign language video is provided for all media content that contains audio.
Language

(Prerecorded)
(Level AAA)




l&m. 0 When audio description cannot be added to video due to audio timing (e.g., insufficient
Audio Description pauses in the audio), an alternative version of the video with pauses that allow audio
(Prerecorded) descriptions is provided.
{Level AAA)
L.2.8 Media ] A descriptive text transcript is provided for all pre-recorded media that has a video
Alternative track. For optimal accessibility, WebAIM strongly recommends transcripts for all
{Prerecorded) multimedia content.
{Level AAA)
1.2.9 Audio-only O A descriptive text transcript (e.g., the seript of the live audio) is provided for all live
(Live) content that has audio.
{Level AAA)

Guideline 1.3 Adaptable:

Create content that can be presented in different ways (e g " surnpler iayout) without losing information or structure

1,3,1.Info and
Relationships
(Level A)

I Recommendations

{J Semantic markup is used to designate headings (<h1>), regions/landmarks, lists (<ul>,
<ol>, and <dl>), emphasized or spemal text (<strong>, <code>, <abbr>, <blockquote>,
for example), etc. Semantic markup is used appropriately.

0 Tables are used for tabular data and data cells are associated with their headers. Data
table captions, if present, are associated to data tables.

[1 Text labels are associated with form input elements. Related form elements are grouped
with fieldset/legend. ARIA labelling may be used when standard HTML is insufficient.

1.3.2 Meaningful

(1 The reading and navigation order (determined by code order) is logical and intuitive.

(WCAG 2.1 -

Sequence

{Level A)

wﬁﬁemp_r}_z 03 Instructions do not rely upon shape, size, or visual location (e.g., "Click the square icon

C_h«':l,l;aigtmﬁtl_fﬁ to continue” or "Instructions are in the right-hand column"),

(Level A) 0 Instructions do not rely upon sound (e.g., "A beeping sound indicates you may
continue.").

_3_4.0_H§11Lm ‘| O Orientation of web content is not restrlcted to only portralt or lanciscape, unless a

(WCAG 2.1 - specific orlentatlon is. necessary R SR

Level AA) _ 5

1.3.5 Identify - O Input fields that collect certain types of user 1nformat10n have an approp1 1ate

input Purpose - -

autocomplete attnbute deﬁned

Purpose .

Level AAA)

1.3.6 Identify

ol O ARIA is used, where appropriate, to enhance HTML semantlcs to better.ldentlfy the '
(WCAG 21 - b

[1 HTML5 regions or ARIA landmarks are used to identify page reglons : S

" purpose of interface components.

Guideline 1.4 Distinguishable:

Make it easier for users to see and hear content mcludmg separatmg foreground from background

‘Success Criteria -

Recommendatlons

1.4.1 Use of Color

01 Color is not used as the sole method of conveying content or distinguishing visual

(Level A) elements.

O Color alone is not used to distinguish links from surrounding text unless the contrast
ratio between the link and the surrounding text is at least 3:1 and an additional
distinction (e.g., underline) is provided when the link is hovered and receives focus.

1.4.2 Audio [ A mechanism is provided to stop, pause, mute, or adjust volume for audio that
Control (Level A) automatically plays on a page for more than 3 seconds.




1.4.3 Contrast

(1 Text and images of text have a contrast ratio of at least 4.5:1.

Level AA)

{____l(ll\flgnlmum [J Large text - at least 18 point (typically 24px) or 14 point (typically 18.66px) and bold -
vel AA) .
has a contrast ratio of at least 3:1.
1.4.4 Resize text 0 The page is readable and functional when the page is zoomed to 200%. NOTE: 1.4.10
(Level AA) (below) introduces a much higher requirement for zoomed content.
1.4.5 Images of 0) If the same visual presentation can be made using text alone, an image is not used to
Text (Level AA) present that text.
1.4.6 Contrast g Contrast 0 Text and images of text have a contrast ratio of at least 7:1.
L_____I(EH anced £1 Large text - at least 18 point (typically 24px) or 14 point (typically 18.66px) bold - has a
evel AAA) .
contrast ratio of at least 4.5:1.
1.4.7 Low or No 0 Audio with speech has no or very low background noise so the speech is easily
Background distinguished.
Audio
(Level AAA)
1.4.8 Visnal Blocks of text over one sentence in length:
w [} Are no more than 80 characters wide.
7 Are NOT fully justified (aligned to both the left and the right margins).
O Have adequate line spacing (at least 1/2 the height of the text) and paragraph spacing
(1.5 times line spacing).
{1 Have a specified foreground and background color. These can be applied te specific
elements or to the entire page using CSS (and thus inherited by all other elements).
0 Do NOT require horizontal scrolling when the text size is doubled.
1.4.9 Images of 0] Text is used within an image only for decoration (image does not convey content) OR
Text (No when the information cannot be presented with text alone.
Exception
{Level AAA)
1.4.10 Reflow - | 01 No loss of content or functionality occurs and horlzontal scrolhng 1s avmded When _ s
(WCAG2.1.. - content is presented at a width of 320 pixels. - i
Level AA) . o This requires responsive design for most web sites. This is best tested by settmg the
S browser window to 1280 pixels wide and then zooming the page content to. 400% :
[ Content that requires horizontal scrolling, such as data tables cornpiex 1mages (such as B
maps and charts), toolbars, ete. are exempted - . SR
JM@& "0 A contrast ratio of at least 3 1is present for dlfferentlatlng graphical ob] ects (such as
Contrast - ~icons and components of charts or graphs) and author-customized interface:: '
(WCAG 2.1__._ ccomponents (such as buttons, form controls, and focus 1nd1cat0rs/ outhnes)
Level AA) - 1 The various states (focus, hover, active, etc.) of author-custon'nzed mteractwe _ '
OIS components must all present 3:1 contrast Sl
_"—‘.12—T0Xt : 1 Ne loss of content or fnnctlonahty occurs when the user adapts text line helght/ spacmg _
Spacing . o) c- to 1.5 times the font size, paragraph spacing to 2 times the font swe word spaclng to 16 :
(WCAG 2, 1 Ut T times the font size, and letter spacing to 12 times the font size. AR

0 This is best supported by avmdmg pixei helght deﬁnltlons for elements that contam
text. . T _ : . Do

1.4.13 Content on

Hover or Focus .

(WCAG21
Level AA) - .

00 When additional content is presented on hover or keyboard focus

U The newly revealed content can be dismissed {generally via the Esc key) mthout movmg k
the pointer or keyboard focus, unless the content presents an 1nput €ITor Or does not :
obscure or interfere with other page content. : - e

{1 The pointer can be moved to the new content without the content dlsappearmg

11 The new content must remain visible until the pointer or keyboard focns is moved away .
from the triggering control, the new content is dismissed, or the new content isno. '
longer relevant.




Principle 2: Operable
Interface forms, controls, and navigation are operable

Guideline 2.1 Keyboard Accessible:

2.1.1 Kevboard

Make all functionality available from a keyboard

‘Success Criteria | Recommendations 5 i nn

[1 All page functionality is available using the keyboard, unless the functionality cannot be

(Level A) accomplished in any knewn way using a keyboard (e.g., free hand drawing).
[ Page-specified shortcut keys and accesskeys (accesskey should typically be avoided) do
not conflict with existing browser and screen reader shortcats.
2.1.2 No (1 Keyboard focus is never locked or trapped at one particular page element. The user can
gfj b(;&z' 31 Tra navigate to and from all navigable page elements using only a keyboard.
eve

2.1.3 Keyboard

{No Exception)
{Level AAA)

11 All page functionality is available using the keyboard.

2.1.4 Character -
Key Shortcuts .-
(WCAG21 =
Level A)

{1 If a keyboard shortcut uses printable character keys, then the user must be able to RRTIEAR
disable the key command, change the defined key to a non-printable key {Cirl, Alt, ete),
or only activate the shortcut when an associated interface component or buttonis - -
focused. . T TR

Guideline 2.2 Enough Time:

Provide users enough time to read and use content

‘Success Criteria
2.2.1 Timing

Adjustable
(Level A)

‘Recommendations =

0 If a page or application has a time limit, the user is given options to turn off, adjust, or
extend that time limit. This is not a requirement for real-time events (e.g., an auction),
where the time limit is absolutely required, or if the time limit is longer than 20 hours.

2.2.2 Pause, Stop,
Hide
(Level A)

0 Automatically moving, blinking, or scrolling content (such as carousels, marquees, or
animations) that lasts longer than 5 seconds can be paused, stopped, or hidden by the
user.

(1 Automatically updating content (e.g., a dynamically-updating news ticker, chat
messages, etc.) can be paused, stopped, or hidden by the user or the user can manually
control the timing of the updates.

2.2.3 No Timing
(Level AAA)

O The content and fonctionality have no time limits or constraints.

2.2.4

Interruptions
{Level AAA)

0] Interruptions (alerts, page updates, etc.) can be postponed or suppressed by the user.

2.2.5 Re-

authenticating
{Level AAA)

{1 If an authentication session expires, the user can re-authenticate and continue the
activity without losing any data from the current page.

2.#.6 Timeouts - .
(WCAG21 0
Level AAA)

O Users must be warned of any timeout that could result in data loss, unless the dai_él is
preserved for longer than 20 hours of user inactivity. S I




Guideline 2.3 Seizures:

Do not design content in a way that is known to cause seizures or physical reactions

2.2.1 Three
Flashes or Below
Threshold

(Level A)

| Recommendations

[1 No page content flashes more than 3 times per second unless that flashing content is
sufficiently small and the flashes are of low contrast and do not contain too much red.

2.3.2 Three
Flashes
(Level AAA)

0 No page content flashes more than 3 times per second.

2.3.3 Animation -

from Interactions .
_(_WQAG_z.l o
Level AAA) .

0 Users can disable non-essential animation and movement that is triggered b_ijser 8
interaction. ' : o Cre R

Guideline 2.4 Navigable:

Provide ways to help users navigate, find content, and determine where they are

“Success Criteria®

2.4.1 Bypass
Blocks

(Level A)

Recommendations

D A link is provided to skip navigation and other page elements that are repeated across
web pages.

[) A proper heading structure and/or identification of page regions/landmarks may be
considered a sufficient technique. Because navigating by headings or regions is not
supported in most browsers, WebAIM recommends a "skip" link (in addition to
headings and regions) to best support sighted keyboard users.

2.4.2 Page Titled
{Level A)

[ The web page has a descriptive and informative page title.

2.4.3 Focus Order
{Level A)

{] The navigation order of links, form elements, etc. is logical and intuitive.

2.4.4 Link 01 The purpose of each link (or form image button or image map hotspot) can be

Purpose (In determined from the link text alone, or from the link text and its context {e.g.,

Context surrounding text, list item, table cell, or table headers).

(Level A) 01 Links (or form image buttons) with the same text that go to different locations are
readily distinguishable.

2.4.5 Multiple M Multiple ways are available to find other web pages on the site - at least two of: a list of

Ways related pages, table of contents, site map, site search, or list of all available web pages.

(Level AA)

2.4.6 Headings (1 Page headings and labels for form and interactive controls are informative. Avoid

and Labels duplicating heading (e.g., "More Details") or label text (e.g., "First Name") unless the

(Level AA) structure provides adequate differentiation between them,

2.4.7 Focus 11 It is visually apparent which page element has the current keyboard focus (i.e., as you

Visible tab through the page, you can see where you are).

(Level AA)

2.4.8 Location £1 If a web page is part of a sequence of pages or within a complex site structure, an

(Level AAA) indication of the current page location is provided, for example, through breadcrumbs
or specifying the current step in a sequence {(e.g., "Step 2 of 5 - Shipping Address").

2.4.9 Link G The purpose of each link (or form image button or image map hotspot) can be

%pﬂsgﬂwxljik determined from the link text alone.

nly) . . . .
(Level AAA) (3 There are no links (or form image buttons) with the same text that go to different

locations.




2.4.10 Section
Headings

{Level AAA)

{J Beyond providing an overall document structure, individual sections of content are
designated using headings, where appropriate.

Guideline 2.5 Input Modalities:
Make it easier for users to operate functlonallty through various mputs beyond keyboard

ia’ Recommendatlons o

Gestures

(WeaGza |

oIf multlpomt or path—based gestures {such as pmchmg, swiping, or draggmg acro
“screen) are not essential to the functxonallty, then the functionality can also be

e ' performed w1th a smgle pomt actwation (such as actwatmg a button),
Leveld) RN e
2.5.2 Pointer - “ol OTo help avoid 1nadvertent actwation of controls, avoid non—essentlal down—event (e g .
Q&Imeuﬂ il onmousedown) activation when clicking, tapping, or long pressing the screen. Use '
(WCAG 2.1 onclick, onmouseup, or similar instead. If onmouseup (or snmlar) 1s used you must
Level A). - _ - provide a mechanism to abort or undo the action performed, - :
__S_BM | 0 ¥ an interface component (hnk button, etc.) presents text (or i 1mages of text), the -
Name = .accessible name (label, a]ternauve text, ana—label etc.) for that component must -
(WCAG 2.1 include the v1s1ble text. ' : : Rp
Level AY - - ' . : S
AEA_MM O Functionality that is trxggered by movmg the device (such as shaking or. panmng a’
Actuation - 0= Umobile device) or by user movement {such as waving to a camera) can be dlsabled and
(WCAG 2. 1 : equwakent funcnonahty is prowded wa standard controls hke buttons' . : '
-LEVEIA) . ) o 3 . ) o RTAR S

(WCAG 2.1
Level AAA)

5 5 Target Slze ;'_

1} Clickable targets are at least 44 by 44 pixels i in size unless an alternatwe target of that g
size is provided, the target is inline (such as a link within a sentence), the targetisnot -
author—modlﬁed (such asa default checkbox), or the small target size is. essen’ual to the
~functionality. - : _

(WCAG 2, 1
Level AAA)

-2.5_.6 Co_ncurren_t_ it

| (3 Content does not restrict 1nput toa specrﬁc modahty, such as touch only or keyboard— : :
only, but must support a}ternatwe mputs (such as using a keyboard on a mobﬂe devxce)_._ _

Principle 3: Understandable
Information and the operation of user interface must be understandable.

Guideline 3.1 Readable:

Make text content readable and understandable

Success Criteria -

Recommeudatlons

3.1.1 Language of
age (Level A)

0 The language of the page is identified using the HTML lang attribute (e.g., <html
lang="en">),

3.1.2 Language of

71 The language of page content that is in a different language is identified using the lang

(Level AAA)

Parts (Level AA) attribute {e.g., <blockquote lang="es">).

3.1.3 Unusual 1 Words that may be ambiguous, unfamiliar, or used in a very specific way are defined
Words through adjacent text, a definition list, a glossary, or other suitable method.

{(Level AAA)

314 [t The meaning of an unfamiliar abbreviation is provided by expanding it the first time it
Abbreviations is used, using the <abbr> element, or linking to a definition or glossary.




3.1.5 Reading

0 A more understandable alternative is provided for content that is more advanced than

Level (Level AAA) can be reasonably read by a person with roughly g years of primary education,

a6 0 If the pronunciation of a word is vital to understanding that word, its pronunciation is
Pronunciation provided immediately following the word or via a link or glossary.

{Level AAA) '

Guideline 3.2 Predictable:
Make Web pages appear and operate in predlctable ways

3Success Crltena * Recommendations

3.2.1 On Focus 1 When a page element receives focus, it does not result in a substantial change to the

(Level A) page, the spawning of a pop-up window, an additional change of keyboard focus, or any
other change that could confuse or disorient the user.

3.2.2 On Input £1 When a user inputs information or interacts with a control, it does not result in a

(Level A) substantial change to the page, the spawning of a pop-up window, an additional change

of keyhoard focus, or any other change that could confuse or disorient the user unless
the user is informed of the change ahead of time.

3.2.3 Consistent

[1 Navigation links that are repeated on web pages do not change order when navigating

Navigation through the site.

(Level AA)

SA&TCP_DS_I'S_‘L@_I [t Flements that have the same functionality across multiple web pages are consistently
Identification identified. For example, a search box at the top of the site should always be labeled the
(Level AA) same way.

3.2.5 Change on (7 Substantial changes to the page, the spawning of pop-up windows, uncontrolled
Request changes of keyboard focus, or any other change that could confuse or disorient the user
(Level AAA) must be initiated by the user. Alternatively, the user is provided an option to disable

such changes.

Guideline 3.3 Input Assistance:
Help users avozd and correct mistakes

i | Recommendations

{Legal, Financial,
Data)

3.3.1 Error £1 Required form elements or form elements that require a specific format, value, or

Identification length provide this information within the element's label.

(Level A) 1 Form validation errors are efficient, intuilive, and accessible. The error is clearly
identified, quick access to the problematic element is provided, and the user can easily
fix the error and resubmit the form.

S;SLLQ;_LEIS_QE 03 Sufficient labels, cues, and instructions for required interactive elements are provided

Instructions via instructions, examples, properly positioned form labels, and/or fieldsets/legends.

{Level A)

3;3;3"13}3}‘“% O If an input error is detected (via client-side or server-side validation), suggestions are

Suggestion provided for fixing the input in a timely and accessible manner.

(Level AA)

RMMEM 0 If the user can change or delete legal, financial, or test data, the changes/deletions can

Prevention be reversed, verified, or confirmed.

Prevention (Al
(Level AAA)

{Level AA)

3.3.5Help O Instructions and cues are provided in context to help in form completion and

(Level AAA) submission.

3.3.6 Error 01 If the user can submit information, the submission is reversible, verified, or confirmed.




Principle 4: Robust
Content can be used reliably by a wide variety of user agents, including assistive technologies

Guideline 4.1 Compatible:

Max1mlze compatlb}hty with current and future user agents mcludmg assistive technologies

4.1.1 Parsing [1 Significant HTML/XHTML validation/parsing errors are avoided.

{Level A)
4.1.2 Name, Role, | 0O Markup is used in a way that facilitates accessibility. This includes following the
Value HTML/XHTML specifications and using forms, form labels, frame titles, ete.
(Level A) appropriately.

{1 ARIA is used approprlateiy to enhance accessibility when HTML is not sufﬁ(:lent
QLSMS N Ifan 1mp0rtant status message is presented and focus is not set to that message the o
Megssages .. message must be announced to screen reader users, typically v1a anAR_IA alert orlive
(WCAG2.1 - - region. : : : :
Level AAY " 0

Available online at: webaim.org/standards/weag/checklist

© 2018 - WebAIM



mg POCUMENTS (WINDOWS)
Heading Styles
Create a uniform beading structure throngh nse of

styles in Word, Tis allows screen readers to navigate 2
document and improves accessiblity for everyone.

1. Start a new line to create a heading, or select text to
change 1o & heading.

2. Open the Home tab, and choose the appropriate
heading in the Styfes panel.

3. Headings 1, 2, or 3 can also be assigned using Cirl +

Alr + I, 2, or 3, respectively.

, -
EO L asbecepe asBozcoe AsB0Ct |
veifi~ | TNowmal fNoSpar. Headingl }Heading?! Heading3

Faragraph Lr3 Shyte;

Alternative Text

Tnages can be given appropriate alternative text in
Word, Alt text is read by a screen reader in 2 Word file and
should remain intact when exporing to HIML or PDE

1. Ripht-click on the image | Format Pictare v %
and select Formar Picture. | &y 4 @
A dialog will appear. i

2. Select the Layonr & PP

Properties icon and choose
Alt Toxe.

3. Enter appropriate alt text
only in the Description
field (not the Title field).

See webaim.org/ techniques /aittext for more information.

Columns

Always use true columns, Doq't create columns with Tab,
1. Select the Layosut tzb on the chboa.

2. Select Columns in the Page Setup group.

Dmondice. R
.| ALTERNAYIVE TEXTHERE :

3.  Choose the aumber of columns.

Sprcing

@ ﬁ‘j E " Brmaks - Tndent
i P Tiincddurmbers - TEdeln @ TS Befoee.
Muging Crisntation  Size Y Cafumns, - s
i - - . Jub rypnenation~  Shtught I iEane
Fage Setug: = ourgraph

@ Project GOALS | WebAIM. Al rghts reserved.

CREATING ACCESSIBLE MICROSOFT WORD 2016

Lists

Use true numbered and bulleted lists to cmphasize a
point er a sequence of steps.

1, Select the Home tab on the ribbon,

2. Choose the Numbered List or Bufleted List option
from the Paragraph group.

VRN K M
R A

Cubesd 4 Fonl n

Cafibii{Bedy) vi1
Copy . N

pare
¥ Farmat Paines

B I g uxx %

Paragranhs

Hyperlinks

Word autematically creates a hyperlink when u vser
pastes a full URL onto = page. Tese may not make sense
to sereen seader users, so make sute the link text is unique.

1. Select a hyperlink, right click, and select Hj/per[irzk ar
hic Cerl + k.

2. Change the text in the Text to Display field to 2 more

meaningfi] description.

WebAIM

watchs g eneiballty I sigised

SSGOALS

Data Tables

Accessible tables neced a cfear table strueture and table
beaders 1o help guide 2 screen reader user.

1. Seclect the Tusert tab on
the ribben, then select
Table > Insert Table.

2. 'To add table headers
to the Hrst row, select
Table Tools > Layout on the ibbon, then choose the
Repeat Header Ruws option in the Data section.

E %
B e
Cover Bienk Page

Fagr= Puge fresk
v Tables

Sy

A

AR ima 4

Options in the Desigr tab may be used to change
appearanice but will not provide the necessary accessibility
information,

Accessibility Checker

Word includes an accessibility resource that identifies
ihility issues.

QTR e Eauran.. |

[iezatune. |

Dowa

Phtog vt iesseny

1. Seleet File > Info >
Check for Lisues >
Check Accessibility.

2. Te checker presents
accessbility errors,
warnings, and tips for
making repairs.

Select specific issues to sec

Additional Information at

the bottom of the task pane.

Other Principles

«  FEnsate that font size is sufficient, around 12 points.
*  Provide sufficient contrast.

= Pon’t use color as #he endy way to convey meaning.
»  Provide a fable of contents for long documents.

*  Use simple language.

For a dirtal vession, see ncdac.org/ resources/cheatsheets



Screen readers and Excel

Users who arc blind rely on software called a sceeen reader
to interact with spreadsheets,

* Screen readers will read the cell number os uscrs
navigate from cell to celf (e.g., "Grand Total A 23").

» Spanned cells will be identifed by a screen reader {e.g.,
“Budget A1 through G17). If content spans multiple
cells visually, 2hese cells should be merged. To merge
cells, select Home and the Merge menu.

WOLIE  INSERT  PAGELAYOUT  FORMULAS  DATA  REIEW  VIBW  ADD
e s = - B Miap Tedt Jei
Fonl ] Atlgnme: i3

Merped cells should not be used in tahles. Tey can be
confusing for screen reader users who expect one tow
and/or column header for each cell.

A screen reader user will usually réars with the fret
cell (A1}, so this is a good place to put important
informadon about the sheet,

Be careful with empity rows and columns, While they
may sometimes be necessary to visually separate daea,
they can cause a sereett reader wier o think the sheet
bas ended, even when it has not.

Images and Charts

While images can be given aliernative text in the same
way as other Ofce tools {see other chearsheets}, they
can sometines sutroduce reading order issues and
should typically wo# be added to spreadshesis.
Charts cannot be given alternative fext. Ensure the
datz used to create the chart is available and clearly
structuted, anid preferably precedes the chase,

Other principles

s Spell check is not automatic as it is in Word/
PowerPoint. Make sure to spell check each sheet,

+ Do nof use color alone to convey information,

Assignments {overdue lrtéd) Assignments Oiferdu_e”__ )

_dntroduction. . introduttion Yes,
Chi . . ‘Chaptert  Na
Inaccessible Accessible

© 2014 Project GOALS All rights reserved.

E CREATING ACCESSIBLE SPREADSHEETS IN MICROSOFT
EXCEL 2010/13 (WINDOWS) & 2011 (MAC)

Table ‘Headers’

If your spreadshect includes tables, there is & special way

to add table ‘header’ information that will be read by the

screen reader. Tables can be identifed with formula names

of Title, 'TitleRegion, and others.

= Tese formulas do ot update when the fable changes,
so be sure your table is complete frst.

* ‘Tis ondy works for a single level of beaders. Complex
tables will need to be simplifed or restructured.

One table per sheet:

Tor sheets with A i B 9

one table only, 14 igontact info4m NOT HERE

scicct the cell 2_‘ HERE bhone Email

in the #pper- |3 lion Hardy 8121681563 elfen.hardy@u
Aft cormer of | Gamett 620.668.1752 fay.garreti@un
the table (Ot | ¢ 1g o0 praty 681 227.6247 steve.prattrf; UJ

the table title).
in Windows, select Formulasr> Defne Name and the New
Nanre dialog opens. In Mae, select Insers> Name> Defne
and the Defre Name dialog opens.

I the Niawre feld, replace the existing text with eme of the
Jallowing 3 values, depending on your table layour:

1§ the table has rolwmn and
-t row headers, enter Titke

if the table has row beaders
only, enter RowTitle

oy 1€ the sable bas colump headers
L only, enter CofumnTitle

Don't Confuse "Column” and "Row” headess, Remember
that ColumaTirle is For vertical headess and RowTitle is
for horigental headers, Also be sure to type RowTith ot
ColumuiTitle as one word, without a space.

After entering the correct value in the Name feld, sclect
(k. Although the initial text is still visible, accessibility
information kas been added for a screen teader user,

Only add a Nawme to the frst celt in the table. De wo# repeat
this step for other header cells within the same table.

Contact us at goals@nedac.org or #435.797.3381

Muitiple tables per sheet:

1f a single sheet has wewleiple tables, if the table has sorfable
rolummns, o1 if you want to specify an explict beginning
and end of a tabie, you need w use TiekeRegion.

Select the cell in the spper-left corner of the table (not the
table title). In Windows, select Formulas> [Defhe Nawre
and the New Name dizlog opens. In Mae, select Tnsert>
Narze> Defne and the Defie Name dialog opens.

In the Name feld, enter TiteRegion followed by the
following 4 valwes (no spaces, sepatated by periods):

A & [3
_iContact Infa

1. Unique number within
the sheet {e.g, 7 for prone  Emalt

the frst table) 3 ‘Ellen Hardy BL2.168.1559 ¢t bhardy G
4 ‘jay Garrett §20.669.1752 Ty.garretiond
eTE Tt ta T er T Moy prate @y

e

2, Fest {upper-lefty cell
in the mble (e, A2)
3. Last (lower-right) cell
in the table (e.g., C5)
4, Sheet number (e.g., 2
for the second rab in
the workbook}
Te above table Nazre would
be TitleRegiond A2.C5.2

Note: RowTitleRegion or ColnmnTitleRegion can be used
for tables that only have row or colurnn headers.

After entering the coreect value in the Name feld, select
Ok, Tis table is now accessible. Repeat this process for
every table on the sheet, remembering to select the spper-
left corner celi of each new wble.

Deleting formula names

You may cceasionally create a formula name for the wrong
feld or pive 2 single ccll more than one name. Tesc
unnecessary formula names should be removed.

SN
o B o wdreDg g

1. To remove formula names in
1Findows, select Dormalas™>
Nawre Manager. In Mac select
Inserr> Name> Defus.

2. Ten choose the desired same
and select Delete,

For a digitnl version go to nedac.org/ resonrces| cheatsheets

Made possible by 2 grant from the Fund for the mprovement of Postseconduary Education (FIPSE), US Deparsment of Education. No fficial endorserent fmplied.



PRESENTATIONS (WINDOWS)

Slide Layouts

Use slide layouts provided within PowerPoint to ensure
files have correctly strnctured beadings and lists, and proper
Slide, then choose

reading order.
[N
a fayout from the hewr [
# fanid parir ! e

dropdown. oo e T

1. Select Home » New

LRBy

2. To change a slide layout, '] i i
sclect fome > Layout,

thea choose a layout from the dropdown,

Slide Reading Order

If you Tnsert other content Selection ~ - o

{e.g, 2 text box) it will be Show Al te Ml 1 & ]

read by a screen reader inthe gl oo .

order it is added to the page.  “Testbors - .
Textbios &

To check or fx reading oxder, -

Lomen Maceholder 3
select Home > Arvange > CTe A
Selection Pane. Reading crder
is shown in reverse, bottom fo top. Click and drag or use
the acrow buttons to change reading order.

Alternative Text

Images should be given appropriate alternative text in
PowerPoint. Tis alt text is read by a screen reader in a
PowerPoint file and should remain intact when exporting
w0 HTML or PDE

1. Right-click on the image %f“‘.;.{ﬁﬂmfm o T
and choose FParmat [ ._\—_.“5: -
Picture, i A

[N roilven

2. Select the Size ¢ et

L e

Properties icon and
choose Alt Text.

3. Enter approptiate alt text 3
only in the Description
field {not the Title field). ;

See webaim.org/techniques/

alttext for moze information.

© Project GOALS | WebAIM. All righes reserved.

CREATING ACCESSIBLE MICROSOFT POWERPOINT 2016

Data Tables

Accessible tables need a clear
table structure and table headers
10 help guide 4 screen reader
USCLL

+  Scleet the fitserr tab on the
sibbon, then seleet Table >
Insert Table,

o Keep tables simple. Teve is
no way to add table header
information in & way that will be identified by a

. Pict
New
Slida~

Skides Tables

screen reader,
+  Ifyou have Adobe Acrobat Pro (not just the free

Reader}, save your presentation to PDF and add rable
headers in Acrobat Pro.

Hyperinks

PowerPoint antomatically creates a hyperlink when a uscr
pastes a full URL onto a stide and presses Enter ot Space.
Tese may not make sense to screen reader users or others,
5o make the link text deseriptive.

1, Select a hyperink, tight click, and select Edir
Hyperlink or hit Crrl + k.

2. Change the text in the Text to Display field to a mose
mezningful description.

lotinpetth

ekt uiu.-u

cohex G,

I
ik tyisengter § | A
Ao d 7 [AY ST YA
A § )
dewut

Hyr wl0a - i
fotuewnd | ! Lot | i
R | ;
i
|
i

Cvettha | e
Bocorwnl | g

asppn dipienemag T

|

fox
Mgy

Inser

.- &

SEGOALS  WebAIM

wieftacy el i el

Accessibility Checker

Select specific issues to see
Additional Information at the
bottom of the pane.

Select File > Tnfo.

Sclect the Check for Jsstees button and choose Check
Accessibility,

Ve Accessibility Checker task
panc will show accessibility
errors, warnings, and tips on
how to repair the errors.

infiy

et
LS A,

Other Principles

.

Bnsure font size is sufficiens, 1€ your presentation will
be viewed on a projector, foat size may need to be
even larger.

Provide sufficient contrast. 1€ your presentation will be
viewed on a projectos, sometimes the contrast needs
to be even more pronounced,

Do not use color as #he only way to convey meaning,
Avoid automatic slide transitions,
Use simple slide transitions when possible.

Do not put accessibility information like alternative
text in the Notes pane,

If you have embedded video, ensure it is captioned.
If you have embedded audio, include a transcript.

TF your slides contain animations, ensure they are brigf
and do not distract from the most important content
on the page.

Use séimple language.

Por » digitat version, see nedac.org/resources/chenrshoats



iN ADOBE ACROBAT Xi

1. Run “Make Accessible” wizard

Select Taols from the upper
right corner, then select Aetion |
Wigard > Make Aseeisible from

. » Content Editing -« |
the sidehbar, Select Stars button. -

r.Pages ..
1. 4dd Document Description ¥ Forms .
- Enter a descriptive page . Action Wizard

Title. Other felds are
opticnal.

2. Sef Open Options — Runs
automatically

Eb Create New Action..

% Manage Actions.,
Actions

CREATING ACCESSIBLE PDF DOCUMENTS

2. Add/Change tags

Te TouchUp Reading Order tool allows a user to quickly

add and edit PDF tags and view the reading order of

clements on the page. To edit tags, do the following,

1. From the right-hand
menu, sciect Toolr.

2.Ten select
Avccessibility >
TonchUp Reading
Order. If the
Accessibility option

Draw areclangle acgund Lhe tontent then click
one of the buttons biowr

g ' Maka Ac:uslble

3. Recognige Teoct wsing OCR —
If your PDIF is not #rue fext,
it will he converted into true
text during this step. If you
are not sure if your PDF is

@ Archive Dacuments
Publish Sensitive informals

Optimize for Vieh snd Me

true text, one easy test is to +. Text Hesagnition ©

search for a word that you » Bentarti

know cceurs in the document. If no results are found, it
needs o be converted 1o text.

4., Detest Fors Fislds — Only ascessary if your page
contains fHlable farms.

5. Set Tabk Order Property — Runs automatically

6. Set Reading Langnage

7. Add Tags to Document — PO “ags” provide
accessibility information to srereen readers. If your
document does not have tags they will be added during
this step. You will need to check the quality of these
tags fater on,

Set Aftermate Text R

oo

. Set Alternate Texct —
A window will appear
that allows you to add
alternative text. Use
the arrows 1o move

agelol 5

Mumulm. TiDecorative rgme

!

Sm&(lnm Cil\cll

between images and check
Decorative fgure if the image shouid be dgrored by a
screen reader,

9, Run Aceersibility Full Check — Tis checker will show
additional issues, Right click exrors and warnings and
select Fix to address the issues, S4&ip Kale if the issuc has
been addressed, and Explain to read online help.

© 2013 Project GOALS All rights rescrved.

Contact ns at goals@ncdae.org or §435.787.3381

is pot listed, use the
Options button to

check Accessibility
on the menu,

Tabte bt |

3. When selected, the 17 Shenw poge conte graups "
view on the screen '!";‘9‘ cantent ordur
£51 Stracture lypes
clmngcs.‘ Al of the 5 Shovs table ca "
content is enclosed [9]1Show tablas end ligures ]

in numbered boxes,
Bach of these boxes
represents a tag | e B T |
and the aumber
corresponds with the reading order in the Order panel.

4. Select the S#ructure Types radio button. Te page will
now display tag types instead of reading order.

. Within the TouchUp Reading Order window you will
notice a group of buttons with the names of scveral
common tags. You can use these buttons to assign tags
to selected text or objects. Use the Text button for body
text and the Heading -6 buttons to assign correct
heading levels.

[ Creur PageStructores, . | [ Show Ords banet -]

o

You can also add/edit the following tags in the TowehUp
Reading Order ool

Images and alternative text

1.To tag 2 part of the page as an image, drag a box around
the image and select the Figare button,

2.To add or change alternative text, Right efick on the
image, select Bdif Alternate Text.

3. Lnter the appropriate alternative text in the dialog box.

GOALS

1.Sclect a tabie and then select Table Inspector. Table
header cells will be identifed in red.

2. Select a table or cell by dragging a box through the cells
(not around them or you might select additdonal cells).
Right click on a selected cell(s} and choose Table Celf
Properties. A dialog box will appear,

3. 1f the selected celifs) needs to be tagged as a header,
select the Header Celf option and assign a scope of
cither Row or Colwmn,

Move itermns to/from the background

1. Select an element you wish to move to the background
{i.e., it will be ignored by a screen reades) and press the
background button. Tis may include repedtive headers
or footers.

2.1f 2 part of the page is not in a gray box then it is already
in the background. If it should be read by a screen
reader, select the item and press the appropriate bution
{egz., Texx, Hending 1-6, Figure).

3. Check/edit reading order

Te TouchUp Reading osder tool can alse allow you to
change the reading arder of the page confent so it matches
the visual reading order.

1. Select the Page Confent
Qrder radio button, Reading
order will now be displayed in
the page instead of tag type.

2. Select Show Order Panel.
Te Order Panel will appear
in the left sidebar with
numbers that correspond to
the numbers in the page.

3.'To change the reading order
of an clernent in this panel, cfick and drag the tag to the
location that refects the correct reading order

Note

1t is easier/better to make documents accessible as fhey
are ereated. See our other cheatsheets to make documents
aceessibie in MS Word, PowesPoint, and InDesign.

B Helo allpdt
={H Pagel
% (1] Hello st
- b [2} Thisis atest
g 13} To ses how w|
¥l (4] Image will
Wt (51 Dipadjfi Kk

For a digital version go to nedae.org/ resorces/ chearsheets

Made possible by a grans from the Fund for the Improvement of Posisecondary Education (FIPSE), US Department of Education. No official endarsement inplied,



ADDITIONAL RESOURCES AND TIPS FOR MANAGING WEBSITE
ACCESSIBILITY COMPLAINTS

June 23 - 26, 2019

YouTube, Screen Reader Demonstration {last accessed May 14, 2019).

WebAIM - WAVE (Web Accessibility Evaluation) Tool (last accessed May 14, 2019)

The National Center on Accessible Educational Materials of the Center for Applied Science
Technology (last accessed May 14, 2019) (includes a virtual training center and Cheat Sheets on

accessibility topics).

PEAT — Partnership on Emplovment and Accessible Technology
University of Colorado, Web Accessibility Self-Study Resources (last accessed May 14, 2019).

Georgia Tech, Accessibility Resources (last accessed May 14, 2019).

U.S. General Services Administration, Section 508 Resources (last accessed May 14, 2019).
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